Deepin Polska – Forum

[Rozwiązany] Nie można zainstalować discorda (brak libc++)  

  RSS

arek222
(@arek222)
New Member
Witamy: 2 miesiące temu
Posty: 4
28/12/2018 10:26 am  

witam, mam dość duży problem z instalacją chociażby discorda (sklep wywala, że nie można, a przez terminalowe dpkg instalacja sie przerywa). Troszkę poszperałem w internecie, i wyszło, że nie mam zainstalowanego libc++, i tu też jest to samo. Po pobraniu debianowej paczki, instalator też wywala błąd, a synaptic pokazuje ten pakiet jako "not installable"  (z oficjalnego repo). Proszę o szybką pomoc, dodam, że inne pakiety normalnie się instalują przez dpkg.

This topic was modified 2 miesiące temu by arek222

OdpowiedzCytat
Dany Gee
(@dany-gee)
Member
Witamy: 8 miesięcy temu
Posty: 91
30/12/2018 12:09 am  

Po najnowszych aktualizacjach najwidoczniej brakuje dwóch paczek w systemie (instaluj  w podanej kolejności):

https://packages.debian.org/sid/amd64/libc++abi1-7/download

https://packages.debian.org/sid/amd64/libc++1/download

Po tym instalacja Discorda powinna działać.

Polecam też zablokować aktualizację Discorda z Appstore - wciąż nie naprawili fuckupu z wersjami i appstore będzie Ci nadpisywał Discorda starszą wersją, jeśli nie wydasz tych komend:

sudo aptitude hold discord

...by zatrzymać automatyczną aktualizację paczki discord (Discord sam się aktualizuje tak czy siak), oraz...

sudo apt update

...by zaktualizować cache apta, by pamietał zmianę jaką wprowadziłeś komendą wyżej.

By sprawdzić, czy paczka faktycznie będzie zatrzymana odpalasz:

sudo apt dist-upgrade

Wynik powinien być taki:

Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following packages have been kept back:
discord
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.

Jeśli apt nie zatrzymał paczki, zrestartuj terminal i powtórz komendę zatrzymania - nie wiem czemu, ale czasami "nie łapie" za pierwszym razem.

This post was modified 2 miesiące temu 5 times by Dany Gee

| OS: Deepin 15.8 | MB: ASUS Z170 DELUXE | CPU: i7-6700K | GPU: nVidia GTX 1080 (Driver 387.34) | RAM: 32GB G-SKILL Ripjaws 4 | NET: I219-V Ethernet | AUDIO: NVIDIA GP104 HD Audio Controller | SSD: KINGSTON_SH100S3 | DISPLAY: 50" LG OLED TV 4K@60 FPS |


OdpowiedzCytat
arek222
(@arek222)
New Member
Witamy: 2 miesiące temu
Posty: 4
30/12/2018 2:29 am  

Pakiet z abi w nazwie przeszedł bez problemów, ale drugi już ma niby jakiś kłopot z zależnościami. Wstawiam screen z terminala.


OdpowiedzCytat
Dany Gee
(@dany-gee)
Member
Witamy: 8 miesięcy temu
Posty: 91
30/12/2018 9:39 am  

Nie kombinuj z dpkg - on się najlepiej nadaje do instalacji wielu *.deb np. Libre Office.

Najlepsza metoda instalacji to normalny dwuklik z powłoki graficznej, lub apt w terminalu:

sudo apt install ./nazwa_paczki.deb

Spróbuj i daj znać co wyszło.

Ja wczoraj instalowałem i poszło bez problemu.

| OS: Deepin 15.8 | MB: ASUS Z170 DELUXE | CPU: i7-6700K | GPU: nVidia GTX 1080 (Driver 387.34) | RAM: 32GB G-SKILL Ripjaws 4 | NET: I219-V Ethernet | AUDIO: NVIDIA GP104 HD Audio Controller | SSD: KINGSTON_SH100S3 | DISPLAY: 50" LG OLED TV 4K@60 FPS |


OdpowiedzCytat
arek222
(@arek222)
New Member
Witamy: 2 miesiące temu
Posty: 4
30/12/2018 2:11 pm  

No dalej jest problem, przez apt wywala jakiś błąd, o tym, że pakiet jest nie instalowalny, a przez powłokę graficzną pokazuje, że ma problem z zależnością z libc++1-7. Przekopalem polowę internetu wczoraj zeby samemu znalezc odpowiedz, i nic. Załączam screeny.

https://imgur.com/q2cRBsK

https://imgur.com/RU9oAcD


OdpowiedzCytat
arek222
(@arek222)
New Member
Witamy: 2 miesiące temu
Posty: 4
30/12/2018 2:33 pm  

Dobra, juz doprowadziłem to do dzialania, jeżeli ktoś będzie miał identyczny problem to trzeba zainstalować nie "libc++1" i abi w tej samej wersji ale "libc++1-7" i abi w tej samej wersji, nie wiem, co to daje, ale dziala, co najważniejsze. (daje linki, instalowac w tej kolejnosci)

https://packages.debian.org/sid/amd64/libc++abi1-7/download

https://packages.debian.org/sid/amd64/libc++1-7/download


OdpowiedzCytat
Share:
  
Praca

Proszę Zaloguj Się lub Rejestracja