Deepin Polska – Forum

Instalacja grafiki NVIDIA  

  RSS

sebastiw
(@sebastiw)
Active Member
Witamy: 4 miesiące temu
Posty: 5
02/11/2018 5:48 pm  

Witajcie! Dołączyłem do użytkowników Deepin kilka dni temu i dopiero poznaję ten świat... niestety moja wiedza nt linuxa jest kiepska, dlatego wiele rzeczy to dla mnie "czarna magia".

Na początek mam problem z instalacją sterowników grafiki Nvidia.

System obecnie działa na otwartoźródłowych i czasami grafika szaleje, np. po wybudzeniu z uśpienia ekran się zwiesza, poza tym niektóre programy pokazują nietypowe kolory, kreski itp.

Przełączyłem przez Deepin Graphic Driver manager na opcję zamknięte źródła, ale po instalacji otrzymuję "Informacja zwrotna..." i instalacja się nie udaje.

Zassałem najnowsze sterowniki Nvidia o roszerzeniu .run, ale nie potrafię ich zainstalować.

Czy będziecie tak mili i naprowadzicie początkującego?

Deepin 15.7 x64


OdpowiedzCytat
Dany Gee
(@dany-gee)
Member
Witamy: 8 miesięcy temu
Posty: 91
23/11/2018 2:25 pm  

Cześć,

podaj najpierw co masz za sprzęt, żebyśmy wiedzieli z czym mamy do czynienia, jaką kartą graficzną dokładnie.

Skoro piszesz, że masz jakieś dziwne artefakty na ekranie, to (jeśli sprzęt kilkuletni już) może się okazać, że grafika zaczyna klękać.

Usypianie i zawieszanie linuxa to problem od lat i lepiej jest z tego na linuxie po prostu nie korzystać. Poza tym, nic tak nie orzeźwia systemu jak dobry restart od czasu do czasu  😎 

Skoro wbudowany menedżer sterowników ma problem z instalacją, to może Twoja grafika nie być wspierana.

Wówczas możliwym ostatnim posunięciem może być właśnie ręczna instalacja z pliku. Ale zanim zaczniemy, daj znać jaki masz sprzęt.

Najlepszą opcją do dzielenia się informacjami o sprzęcie jest instalacja programu INXI:
Otwierasz terminal i wpisujesz...

sudo apt install inxi

Gdy się pobierze odpal następną komendę...

inxi -Fxz

... i teraz wklej tu ładnie cały wynik tej komendy sformatowany jako kod.

This post was modified 3 miesiące temu by Dany Gee

| OS: Deepin 15.8 | MB: ASUS Z170 DELUXE | CPU: i7-6700K | GPU: nVidia GTX 1080 (Driver 387.34) | RAM: 32GB G-SKILL Ripjaws 4 | NET: I219-V Ethernet | AUDIO: NVIDIA GP104 HD Audio Controller | SSD: KINGSTON_SH100S3 | DISPLAY: 50" LG OLED TV 4K@60 FPS |


OdpowiedzCytat
sebastiw
(@sebastiw)
Active Member
Witamy: 4 miesiące temu
Posty: 5
25/11/2018 7:07 pm  

hej!

mój błąd, już wklejam info (obecnie działam na Mint, ale chcę wrócić do Deepina jak rozwiążemy temat grafiki):

System: Host: sebastian-PC Kernel: 4.15.0-39-generic x86_64
bits: 64 gcc: 7.3.0
Desktop: Cinnamon 3.8.9 (Gtk 3.22.30-1ubuntu1)
Distro: Linux Mint 19 Tara
Machine: Device: desktop System: MIKROLOG product: ProG33-CH serial: N/A
Mobo: ASUSTeK model: P5K-VM v: Rev 1.xx serial: N/A
BIOS: American Megatrends v: 0902 date: 06/20/2008
CPU: Dual core Intel Core2 Duo E4500 (-MCP-)
arch: Conroe rev.13 cache: 2048 KB
flags: (lm nx sse sse2 sse3 ssse3) bmips: 8832
clock speeds: max: 2200 MHz 1: 1204 MHz 2: 1217 MHz
Graphics: Card: NVIDIA G73 [GeForce 7600 GS] bus-ID: 01:00.0
Display Server: x11 (X.Org 1.19.6 )
drivers: nouveau (unloaded: modesetting,fbdev,vesa)
Resolution: 1680x1050@59.88hz
OpenGL: renderer: NV4B version: 2.1 Mesa 18.0.5 Direct Render: Yes
Audio: Card Intel 82801I (ICH9 Family) HD Audio Controller
driver: snd_hda_intel bus-ID: 00:1b.0
Sound: Advanced Linux Sound Architecture v: k4.15.0-39-generic
Network: Card-1: Marvell 88E8056 PCI-E Gigabit Ethernet Controller
driver: sky2 v: 1.30 port: c800 bus-ID: 02:00.0
IF: enp2s0 state: down mac: <filter>
Card-2: Qualcomm Atheros AR9485 Wireless Network Adapter
driver: ath9k bus-ID: 04:00.0
IF: wlp4s0 state: up mac: <filter>
Drives: HDD Total Size: 1620.3GB (38.1% used)
ID-1: /dev/sda model: OCZ size: 120.0GB temp: 128C
ID-2: /dev/sdb model: ST31500341AS size: 1500.3GB temp: 33C
Partition: ID-1: / size: 110G used: 38G (36%) fs: ext4 dev: /dev/sda1
RAID: No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors: System Temperatures: cpu: 30.0C mobo: 42.0C gpu: 64.0
Fan Speeds (in rpm): cpu: 0 sys-1: 0
Info: Processes: 195 Uptime: 1 day Memory: 4630.5/7976.6MB
Init: systemd runlevel: 5 Gcc sys: 7.3.0
Client: Shell (bash 4.4.191) inxi: 2.3.56

Deepin 15.7 x64


OdpowiedzCytat
Dany Gee
(@dany-gee)
Member
Witamy: 8 miesięcy temu
Posty: 91
26/11/2018 3:19 pm  

A spróbuj zainstalować sterowniki nVidii na Mincie i poobserwuj zachowanie instalatora oraz systemu w ogóle. Instalator sterowników znajdziesz w ustawieniach systemu.

Następnie jak już się wszystko poinstaluje i zadziała, odpal inxi jeszcze raz i zanotuj jaką wersję sterownika Ci zainstalowało.

Wynik wklej tu.

| OS: Deepin 15.8 | MB: ASUS Z170 DELUXE | CPU: i7-6700K | GPU: nVidia GTX 1080 (Driver 387.34) | RAM: 32GB G-SKILL Ripjaws 4 | NET: I219-V Ethernet | AUDIO: NVIDIA GP104 HD Audio Controller | SSD: KINGSTON_SH100S3 | DISPLAY: 50" LG OLED TV 4K@60 FPS |


OdpowiedzCytat
sebastiw
(@sebastiw)
Active Member
Witamy: 4 miesiące temu
Posty: 5
26/11/2018 9:20 pm  

w okienku ZARZĄDZANIE STEROWNIKAMI mam pusto i komunikat: brak własnościowych sterowników w użyciu

nie wiem, co dalej (?)

Deepin 15.7 x64


OdpowiedzCytat
Dany Gee
(@dany-gee)
Member
Witamy: 8 miesięcy temu
Posty: 91
27/11/2018 11:29 am  

To może oznaczać, że Twoja karta oficjalnie nie jest już wspierana. Gdy jest, w oknie tym pokazują się inne sterowniki do wyboru i można je instalować.

Pozostaje Ci ostatnia deska ratunku, czyli instalacja ręczna, która jak się domyślasz, NIE GAWARANTUJE, że zadziała i może skaszanić Ci system, więc przed testami upewnij się, że masz kopię zapasową i bądź gotowy nawet na świeży reinstall systemu.

A robi się to tak:

1. Pobierasz ze strony nVidii stery dla Linuxa odpowiednie dla Twojego modelu karty i architektury systemu (32 lub 64 bit).
2. Przechodzisz do folderu z pobranym plikiem i odpalasz terminal z tego folderu (prawy na pustej przestrzeni w folderze i "Otwórz w terminalu").
3. Albo otwierasz terminal i przechodzisz do folderu z plikiem poprzez komendę: cd /ścieżka/do/folderu/z/plikiem
4. Teraz wklepujesz komendę sudo ./NVIDIA-Linux-x86_64-XXXXX.run (XXXX to wersja Twojego sterownika - po prostu skopiuj nazwę pliku, albo zacznij pisać sudo ./NVI i naciśnij TAB a terminal sam znajdzie plik i wstawi nazwę do końca)
5. Naciskasz enter i jedziesz z koksem modląc się do kogo chcesz by zadziałało.
6. Po instalacji obowiązkowy restart.

This post was modified 3 miesiące temu 3 times by Dany Gee

| OS: Deepin 15.8 | MB: ASUS Z170 DELUXE | CPU: i7-6700K | GPU: nVidia GTX 1080 (Driver 387.34) | RAM: 32GB G-SKILL Ripjaws 4 | NET: I219-V Ethernet | AUDIO: NVIDIA GP104 HD Audio Controller | SSD: KINGSTON_SH100S3 | DISPLAY: 50" LG OLED TV 4K@60 FPS |


OdpowiedzCytat
sebastiw
(@sebastiw)
Active Member
Witamy: 4 miesiące temu
Posty: 5
30/11/2018 6:31 pm  

Po takiej instalacji wysypał się Deepin... 🙂

Deepin 15.7 x64


OdpowiedzCytat
Dany Gee
(@dany-gee)
Member
Witamy: 8 miesięcy temu
Posty: 91
01/12/2018 10:23 am  

A jak poszła instalacja sterowników na Mincie tą metodą?

| OS: Deepin 15.8 | MB: ASUS Z170 DELUXE | CPU: i7-6700K | GPU: nVidia GTX 1080 (Driver 387.34) | RAM: 32GB G-SKILL Ripjaws 4 | NET: I219-V Ethernet | AUDIO: NVIDIA GP104 HD Audio Controller | SSD: KINGSTON_SH100S3 | DISPLAY: 50" LG OLED TV 4K@60 FPS |


OdpowiedzCytat
sebastiw
(@sebastiw)
Active Member
Witamy: 4 miesiące temu
Posty: 5
02/12/2018 7:38 am  

Boje się to ruszać, nie mam teraz za bardzo czasu i siły na reinstall jak się wywali system...

zwłaszcza, że działa poprawnie przy max rozdzielczości itp.

 

ale chrzanić to, spróbuję.

Na razie wywala mi błąd, bo próbuje instalować na uruchomionym serwerze X, co teraz? (przepraszam, jestem laikiem)

This post was modified 3 miesiące temu by sebastiw

Deepin 15.7 x64


OdpowiedzCytat
Dany Gee
(@dany-gee)
Member
Witamy: 8 miesięcy temu
Posty: 91
03/12/2018 9:49 am  

Hmm, czyli chyba trzeba wejść w tryb tekstowy systemu (ALT+CTRL+F2), zalogować się i stamtąd odpalić instalkę.

| OS: Deepin 15.8 | MB: ASUS Z170 DELUXE | CPU: i7-6700K | GPU: nVidia GTX 1080 (Driver 387.34) | RAM: 32GB G-SKILL Ripjaws 4 | NET: I219-V Ethernet | AUDIO: NVIDIA GP104 HD Audio Controller | SSD: KINGSTON_SH100S3 | DISPLAY: 50" LG OLED TV 4K@60 FPS |


OdpowiedzCytat
Share:
  
Praca

Proszę Zaloguj Się lub Rejestracja